Net Cloud Manager Remote Connect Outage
Incident Report for Cradlepoint
Postmortem

Cradlepoint's engineering team has completed a Root Cause Analysis (RCA) of the service disruption that occurred on September 25th 2020. Please follow the link below to view the RCA in our Customer Connect Community. Any questions or concerns please contact Cradlepoint Support.

https://customer.cradlepoint.com/s/article/Service-Degradation-RCA-September-25th-2020

Posted Oct 01, 2020 - 15:06 MDT

Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 09:12 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2020 - 08:53 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 25, 2020 - 08:42 MDT
Investigating
NetCloud Manager is currently experiencing performance degradation where users can not access Remote Connect functionality.

We sincerely apologize for this inconvenience. Our engineering team is looking into the issue and we expect it to be resolved very quickly.
Posted Sep 25, 2020 - 08:36 MDT
This incident affected: Cradlepoint NetCloud (NetCloud Manager).