NetCloud Perimeter Performance Degradation
Incident Report for Cradlepoint
Resolved
We have identified this was a very isolated incident and the issue is resolved.
Posted Aug 05, 2019 - 12:28 MDT
Investigating
NetCloud Perimeter is currently experiencing performance degradation when adding new clients to an overlay network.

We sincerely apologize for this inconvenience. Our engineering team is looking into the issue and we expect it to be resolved very quickly.
Posted Aug 05, 2019 - 11:09 MDT
This incident affected: Cradlepoint NetCloud (Cradlepoint NetCloud Perimeter).