NCM Performance Degradation
Incident Report for Cradlepoint
Postmortem

Cradlepoint's engineering team has completed a Root Cause Analysis (RCA) of the service disruption that occurred on October 28th 2021. Please follow the link below to view the RCA in our Customer Connect Community. Any questions or concerns please contact Cradlepoint Support.

https://customer.cradlepoint.com/s/article/Service-Degradation-RCA-Oct-28th-2021

Posted Oct 28, 2021 - 18:34 MDT

Resolved
This incident is resolved. We apologize for any inconvenience.
Posted Oct 28, 2021 - 11:43 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2021 - 10:17 MDT
Update
We are continuing to work on addressing the issue.
Posted Oct 28, 2021 - 09:29 MDT
Identified
We have identified the issue and are implementing the fix now.
Posted Oct 28, 2021 - 08:59 MDT
Update
NetCloud Manager is currently experiencing performance degradation with logging in and slow performance. During this period, all Cradlepoint endpoints will continue to remain operational but devices and users could experience limited access to NetCloud Manager.

We sincerely apologize for this inconvenience. Our engineering team is looking into the issue and we expect it to be resolved very quickly.
Posted Oct 28, 2021 - 08:31 MDT
Investigating
NetCloud Manager is currently experiencing performance degradation with logging in and slow performance. During this period, all Cradlepoint endpoints will continue to remain operational but devices and users could experience limited access to NetCloud Manager.

We sincerely apologize for this inconvenience. Our engineering team is looking into the issue and we expect it to be resolved very quickly.
Posted Oct 28, 2021 - 08:10 MDT
This incident affected: Cradlepoint NetCloud (NetCloud Manager).