Cradlepoint Cascade - Issues with Deal Registration Submissions
Incident Report for Cradlepoint
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 13:15 MST
Investigating
Cascade is currently experiencing issues with Deal Registration submissions. Engineering teams are currently engaged on root causing and resolving the issue.

For any immediate ordering needs, please contact your Cradlepoint Partner Account Manager.

We apologize for any inconvenience this is causing.
Posted Jan 11, 2022 - 11:52 MST
This incident affected: Cradlepoint NetCloud (Cradlepoint Cascade (Partner)).