NetCloud Manager Outage
Incident Report for Cradlepoint
Postmortem

Cradlepoint's engineering team has completed a Root Cause Analysis (RCA) of the service disruption that occurred on June 18th 2020. Please follow the link below to view the RCA in our Customer Connect Community. Any questions or concerns please contact Cradlepoint Support.

https://customer.cradlepoint.com/s/article/Service-Disruption-RCA-June-18th-2020

Posted Jun 26, 2020 - 17:12 MDT

Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 18:46 MDT
Monitoring
Device connections have been restored and the team is still monitoring to ensure the service is back to normal operational performance.
Posted Jun 18, 2020 - 17:32 MDT
Update
We have updated the system to be able to restore device connectivity levels are are actively monitoring.
Posted Jun 18, 2020 - 16:48 MDT
Update
We have identified resolution steps and are actively applying to restore the service as quickly as possible.
Posted Jun 18, 2020 - 15:47 MDT
Update
The system degradation continued and NetCloud Manager is currently unable to accept device connections. We are actively working on this issue and sincerely apologize for any inconvenience.
Posted Jun 18, 2020 - 15:12 MDT
Update
We are still actively working on properly addressing this issue to recover the service performance as quickly as possible.
Posted Jun 18, 2020 - 14:48 MDT
Identified
NetCloud Manager is currently experiencing performance degradation where users may intermittently be unable to login or device connectivity may be slower.

We sincerely apologize for this inconvenience. Our engineering team is looking into the issue and we expect it to be resolved very quickly.
Posted Jun 18, 2020 - 14:04 MDT
This incident affected: Cradlepoint NetCloud (NetCloud Manager).