This issue has been resolved, and access to Ericsson Enterprise Wireless University is now accessible via NetCloud Manager.
Posted Feb 18, 2026 - 10:26 MST
Update
We continue to work with our third party provider to restore access to Ericsson Enterprise Wireless University through NetCloud Manager. We hope to have the issue resolved quickly.
Posted Feb 17, 2026 - 09:01 MST
Update
We continue to work with our third party provider to restore access to Ericsson Enterprise Wireless University through NetCloud Manager. We hope to have the issue resolved quickly.
Posted Feb 16, 2026 - 08:02 MST
Identified
We have identified the issue and are working with our third party provider to resolve as quickly as possible.
Posted Feb 13, 2026 - 12:37 MST
Investigating
Access to Ericsson Enterprise Wireless University through NetCloud Manager is currently unavailable. We are actively investigating this issue.
Posted Feb 13, 2026 - 10:58 MST
This incident affected: Websites and Portals (University (www.cradlepointuniversity.com)).