Cradlepoint Customer and Partner Connect are Unavailable

Incident Report for NetCloud us0 Instance

Resolved

This incident has been resolved.
Posted May 11, 2021 - 19:43 MDT

Monitoring

This issue has been resolved by our 3rd party service and related functionality has been restored in NetCloud Manager. Our engineering team will continue to monitor.
Posted May 11, 2021 - 18:02 MDT

Update

We are continuing to work on a fix for this issue.
Posted May 11, 2021 - 16:17 MDT

Identified

We have identified an issue with Cradlepoint Customer and Partner Connect. Currently, users are not able to access Cradlepoint Connect through NetCloud Manager to perform activities such as submit technical support cases or view forums. We are actively monitoring the status of our external 3rd party services that are impacting this functionality.

We apologize for any inconveniences.
Posted May 11, 2021 - 16:15 MDT
This incident affected: NetCloud Manager Cloud Services - Americas us0 (Account Login / User Interface / API).